Physics 103/105 labs start Monday September 27, 2010. It's important that you go to the lab section that you signed up for. We will be expecting you!

You should have a lab book and a scientific calculator when you come to your first lab. (See details in the Orientation section following.)

Each week, before you come to lab:

- Read the procedure for that week's lab, and any additional reading required.
- The **Prelab problems** are optional, but please work them if it appears that they will be of help to you.

Also, for the first week:

- Read the “Orientation to Physics 103/105 Lab” and Appendices A and B.
# Physics 103/105 Lab Manual

## Table of Contents

<table>
<thead>
<tr>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lab Schedule</td>
<td>iii</td>
</tr>
<tr>
<td>Orientation to Physics 103/105 lab</td>
<td>iv</td>
</tr>
<tr>
<td>Lab #1: Motion in Two Dimensions</td>
<td>1</td>
</tr>
<tr>
<td>Lab #2: Forces in Fluids</td>
<td>17</td>
</tr>
<tr>
<td>Lab #3: Collisions in Two Dimensions and Conservation Laws</td>
<td>31</td>
</tr>
<tr>
<td>Lab #4: Friction during Constant Acceleration on an Inclined Plane</td>
<td>37</td>
</tr>
<tr>
<td>Lab #5: Loop-the-Loop and Falling Off a Log</td>
<td>51</td>
</tr>
<tr>
<td>Lab #6: Precision Measurement of ( g )</td>
<td>57</td>
</tr>
<tr>
<td>Lab #7: Coupled Pendulums and Normal Modes</td>
<td>65</td>
</tr>
<tr>
<td>Lab #8: The Speed of Sound and Specific Heats of Gases</td>
<td>75</td>
</tr>
<tr>
<td>Appendix A: Data Analysis with Excel</td>
<td>97</td>
</tr>
<tr>
<td>Appendix B: Estimation of Errors</td>
<td>101</td>
</tr>
<tr>
<td>Appendix C: Standard Deviation of the Mean of ( g )</td>
<td>111</td>
</tr>
<tr>
<td>Appendix D: Polynomial Regression</td>
<td>118</td>
</tr>
<tr>
<td>Date</td>
<td>Topics</td>
</tr>
<tr>
<td>-------------------</td>
<td>---------------------------------</td>
</tr>
<tr>
<td>Sept 20-24</td>
<td>NO LAB</td>
</tr>
<tr>
<td>Sept 27-30</td>
<td>Experiment # 1</td>
</tr>
<tr>
<td></td>
<td>Motion in 2 Dimensions</td>
</tr>
<tr>
<td>Oct 4-7</td>
<td>Experiment # 2</td>
</tr>
<tr>
<td></td>
<td>Fluids</td>
</tr>
<tr>
<td>Oct 11-14</td>
<td>Experiment # 3</td>
</tr>
<tr>
<td></td>
<td>Collisions</td>
</tr>
<tr>
<td>Oct 18-20</td>
<td>Experiment # 4</td>
</tr>
<tr>
<td></td>
<td>Friction</td>
</tr>
<tr>
<td>Oct 25-29</td>
<td>NO LAB</td>
</tr>
<tr>
<td>Nov 1-4</td>
<td>NO LAB</td>
</tr>
<tr>
<td>Nov 8-11</td>
<td>Experiment # 5</td>
</tr>
<tr>
<td></td>
<td>Loop-the-Loop</td>
</tr>
<tr>
<td>Nov 15-18</td>
<td>Experiment # 6</td>
</tr>
<tr>
<td></td>
<td>Measurement of $g$</td>
</tr>
<tr>
<td>Nov 22-25</td>
<td>NO LAB</td>
</tr>
<tr>
<td>Nov 29-Dec 2</td>
<td>Experiment # 7</td>
</tr>
<tr>
<td></td>
<td>Coupled Pendula</td>
</tr>
<tr>
<td>Dec 6-9</td>
<td>Experiment # 8</td>
</tr>
<tr>
<td></td>
<td>Speed of Sound</td>
</tr>
<tr>
<td>Dec 13-16</td>
<td>Make-up labs</td>
</tr>
</tbody>
</table>
Orientation to Physics 103/105 Lab

WELCOME TO PHYSICS 103/105 LAB!

Physics 103/105 labs start the SECOND full week of classes. It's important that you go to the lab section that you signed up for. We will be expecting you!

You should have a lab book and a scientific calculator when you come to your first lab. (See details in the Orientation section following.)

Each week, before you come to lab:

- Read the procedure for that week's lab, and any additional reading required.

The Prelab problems are optional, but please work them if it appears that they will be of help to you.

Also, for the first week:

- Read the "Orientation to Physics 103/105 Lab" material below.

I. What Physics 103/105 labs Are Like

You will soon find that Physics 103/105 Lab is not like any lab you've had before. You will be expected to think and be creative, not just follow instructions. The lab manuals for each experiment will step you through many of the new techniques that you will need, but you will not generally be given recipes to follow for each experiment. The manual for each week will typically describe a basic experiment that all students will be expected to complete. Beyond that, the manual will suggest a variety of additional experiments and extensions that you may find interesting and challenging. You can pick one or more of these to work on, or you can invent a new experiment on your own. The lab employs versatile equipment that will allow you to do the “standard” experiment quickly and then branch out to new challenges that match your interests and expertise.

In Physics 103/105 Lab, you will work in teams of two or three students. (Larger groups become unwieldy.) Your AI will randomly assign teams. Students may work in the same groups each week, but there will likely be changes in the groups during the term. Please be flexible about letting others work with you, or splitting up your existing team if it makes the groups more even. Your AI may mix reassign groups occasionally to give people a
You will find that learning how to plan and work together will be crucial to the effectiveness of your team. Among your responsibilities in physics 103/105 is to be sure that all of the people in your team contribute to your success. Take turns performing the experiment and using the computer so that every team member gets a chance to “drive”. If one or more of your team members seems lost, take a few minutes to get them up to speed—you’ll need their input later when things get tougher! You will also find that you learn a lot by discussing problems with others, even when you think you’re the one doing the teaching. Most scientists and engineers today work in teams, some large and some small, depending on the size of the task.

Periodically, your AI will come by your lab bench and ask you questions about what’s going on. Of course, you can ask your AI questions about what’s going on too. You will find that your AI is a great resource. On the other hand, you shouldn’t be surprised if your AI doesn’t answer all of your questions directly. Your AI’s job is to help you learn, and sometimes the best way to do that is by making you struggle on your own for a while.

Sometimes, you will learn things in lab before you see them in lecture or precept. In other cases, you will see topics in lab that won’t be covered in the lecture at all. While physics labs are good for helping you solidify what you learn in lecture (either before or later), they are also great for going beyond the lecture, showing you additional techniques and phenomena that you won’t see in other parts of your physics course.

Among the important techniques you will learn in lab that won’t be covered in lecture are data analysis and error analysis (= analyzing the uncertainty in your measurements). These are critically important skills that you will need in your professional lives as scientists and engineers, and things you may not learn any place else. In many cases, estimating the uncertainty on your measurements will be the most difficult part of a lab.

The process you will go through in this lab closely approximates the working experience of professional scientists and engineers. It goes something like this: your team decides on an interesting investigation, makes a plan, organizes to do the work, gets and analyzes data, thinks about the results, and repeats or improves the experiment until you are satisfied with your accomplishments. The most valuable tool that you have in the lab (or anywhere else) is your common sense. A good scientist or engineer is always asking: Do we have a clear idea of what are we trying to do? Do our results so far make sense? Is there a better way to do it? Practicing scientists almost never get their final results the first time they do an experiment. Don’t just go through the motions: plan, think, and understand. Try to get to the result quickly, think about it, and then do a better experiment or try a variation to test a “what if?” idea. Along the way you will learn a lot of physics, especially if you are thinking and discussing (or arguing about) ideas with your teammates.
II. Notebooks

For physics 103/105 labs, you will not turn in any formal laboratory reports. Instead, you will be required to keep a notebook. You can get one at the U-Store. The spiral bound 5X5 QUADRILLE RULED (80 Sheets 11" X 8.5" Green tint) is recommended (cheap and adequate). If those are not available, try to get something close; quadrille paper is particularly important.

Start each week’s lab on a new page; write the date at the top, and who your other team members are. If you attend a different lab session than the one to which you are formally assign, also write your formal lab section. From that point on, your notebook should be a comprehensive record of everything you do and think in 103/105 lab that day; sort of like a diary or a journal.

Your lab notebook is not the same as a “lab report.” It contains similar information, but in much less polished form. DO NOT waste time making your notebook look pretty. It should be neat enough to be easily understandable, BUT NOT NEATER. Feel free to cross things out, draw arrows, make freehand sketches, and cuss. Use scissors and tape to include printouts in your notebook whenever you use a computer to make a diagram or a graph. Also, include all of the things you tried that didn’t work out how you planned; they’re an important part of what you are learning too. Just be sure that your notebook is easily readable, and always take some time to write some understandable sentences explaining what you are about to do, what you’ve just done, and what you have learned from it.

Suppose, for instance, that you have just measured the speed of a car that has rolled down a ramp, and it didn’t come out like you expected it to. You might write:

“The value we came up with for the speed of the car was 4.2 m/sec; that’s about 15% lower than we expected. Maybe friction (while rolling) is more important than we thought? Jen suggested we try raising the ramp: that way the speed of the car should be greater, and the effect of friction should be (relatively) smaller.”

You could then try the experiment again, including the new data and a new graph in your notebook, along with your conclusions:

“Dang! The speed increased to 6.7 m/sec, but now that’s 25% lower than we expected it. The problem didn’t get better, it got worse! So much for that idea: we can conclude that friction while rolling down the ramp probably isn’t the problem....”

Notice that although the problem isn’t solved yet, the student was able to draw a partial conclusion: that the discrepancy in speed is not due to rolling friction. These conclusions are vital for your notebook. Without them, your notebook is just a bunch of meaningless numbers. Of course, a final paper based on this experiment might never include this degree of detail, especially about this part of the experiment that seems to be producing inconsistent results. But solving these difficulties is an important part of your experience in lab, and your description of your experience is what your notebook is all about.
Students are often unsure about how much detail to put in the notebook. What we most want to see in your notebooks is evidence of thinking, and not just “correct” results.

At the end of your lab period, leave your notebook on the shelf in your lab room for your AI to grade. DO NOT REMOVE your notebook from the lab room. This rule is for your own benefit. When students take their notebooks home, it starts a sort of arms race for who has the prettiest colored graphs and the best spelling. Don’t waste time beautifying your notebook; it's a record, not an artwork.

Professional researchers rely heavily on their notebooks for reference when they write the papers or reports describing their work. Notebooks are the means to recall and check, sometimes years later, what went on in the lab. Many researchers have their notebooks regularly notarized, in case they are needed for patent verification. It's important to learn how to keep a good lab notebook. Someday your job may depend on it.

III. Prelab work

Please read (and think about) the lab instructions before coming to lab. Otherwise you will waste a lot of time in getting up to speed. If your lab partners aren’t reading the write-ups ahead of time, ask them to do so. Many of the writeups refer you to Appendix materials which you will be expected to read carefully.

You can also complete the optional “prelab problems” at the end of each set of lab instructions before coming to lab. The prelab problems are not too hard or time consuming, but they can be helpful in getting you prepared for each week’s material.

IV. Grading

The main intent of Physics 103/105 lab is to offer you a chance to be scientifically and technically creative. We want you to form and pursue ideas. Our evaluation of your work will depend a lot on your creativity and understanding, and very little on “getting the right answer.” Experimentation is hard, and even good experiments don’t always turn out how you plan them to be.

Golden rule of 103/105 lab grading: In general, we won’t hold it against you if an experiment doesn’t produce the answer you think it should or doesn’t quite get finished, as long as you worked hard and were intellectually and creatively engaged for your entire lab period. The flip side of the pact is this: In general, you are required to be intellectually and creatively engaged for your entire lab period, even if your experiment goes well. If you finish one experiment, then think of another.

Whatever you do, don’t just sit around doing nothing. Your grade will suffer, and you will attract unwanted attention.
For Physics 103, the Lab grade is worth 15% of your course grade in the class (Physics 105 will announce its grading scheme in class). But for both classes, your lab grade is calculated as follows:

75% Notebooks: Graded after each lab for completeness, thoughtfulness, and readability.
25% Participation: Graded for each lab for creativity and industry.

V. Attendance

Attendance each week is vital in Physics 103/105 Lab. If you must miss your regular lab section due to illness, University-related travel, or religious reasons, contact the Ph103 Lab Manager: Prof. Kirk McDonald (kirkmcd@princeton.edu) by email to arrange to go to another lab section.

*Not Completing one lab will lower your PHY 103/105 course grade by one full letter grade. Not Completing two labs will result in automatic failure of the entire course.*

If you realize that you have missed a lab because you have slept through it or have forgotten what day it was, then you can make it up later that week in another lab section. If you realize you have missed your lab, try to contact Prof. McDonald. However, if you have only one time slot left that you can make up the laboratory, don’t wait to hear from the department office; just show up, explain the situation to the AI, and we’ll sort the paperwork out later.

Makeup labs will offered, by appointment with Prof. McDonald, during the last full week of class, Dec. 13-17. However, it is strongly recommended that in case of schedule difficulties some week, you attend some lab session that week, and work with other students on the lab.

VI. Feedback

Physics 103/105 Labs are always changing. As always, we think we’ve nailed it, but chances are we’ve missed some things. To help us do better in future weeks and future years, we want to hear feedback from you.

If you have any questions, comments, or concerns about Physics 103/105 Lab, please bring them up with your AI, the lab manager, or the course head. Thanks!

Physics 103/105 Labs start on Monday, September 27, 2010.
See you there!
LAB #1: Motion in Two Dimensions

BEFORE YOU COME TO LAB:

1. Read the Orientation to Physics 103/105 lab, above.
2. Read the Introduction and Physics Background sections, below.
3. Read Taylor's Sections 1.5-1.6 and 2.1-2.2. (You should have read Sections 1.1-1.3 last week.) If you are unfamiliar with spreadsheet programs, read Appendix A – Data Analysis with Excel
4. If you find it helpful, work the optional PreLab problem set attached at the end; You can discuss this with your AI at the beginning of the lab.

This lab is about motion, and how to describe it. The intuitive precision that a baseball player shows in moving to exactly the right location to catch a fly ball immediately after it leaves the bat is amazing. But in the technical realm it is useful to make a mathematical description. Describing motion requires measuring position and time. In Galileo's era, a measurement-based approach was in its infancy. But it is fundamental to all science.

Much of your time in this lab will be spent mastering a video-based method of measuring position and time. But don't lose sight of what is really important – characterizing motion itself. In what sense does motion sustain itself, and how do external agents affect it? Can two-dimensional motion be analyzed in terms of two separate descriptions, each involving only one dimension? Newton's simple equation, $F = ma$ (with $F$ and $a$ being vectors), underlies a formal answer to such questions. But formalism has to be related to measurement and intuition. That is what this lab is really about.
A. Introduction

In this lab you will use a video camera to make videos of moving objects, and a computer to analyze the motion. It is important that every member of your group learn how to use the computer and software. Be sure that you all take turns and that, when you are the operator, your partners understand what you are doing.

The programs that you will use can be activated by clicking on icons on your computer's Desktop. These include:

- **VideoPoint Capture**: We use this to record a video.
- **VideoPoint**: the program in which you will analyze your videos, by measuring positions in the video frames, and graphing and analyzing the results.
- **Excel 2003 (with WPTools)**: an extension of the common Excel spreadsheet program, which allows more detailed calculations and graphing. The WP (Workshop Physics) extensions make it easy to use Excel's sophisticated graphing functions.
- **Student Data**: a folder with space for you to put your files.
- **Word 2003**: which can be used for note taking, and printing camera images.

The folder **Worksheets and Tools** will not be needed in this lab.

Capturing a Single Still Image

Your first task is to capture a still picture of yourself to give to your lab instructor to help him or her remember your name and face.

1. Open **VideoPoint Capture**. A window pops up labeled **Choose Capture File**. The default file name is **capture**. Simply click **Save** to go to the next step.

2. A window labeled **Preview** appears, which displays whatever your camera is viewing at the moment. Wave a hand in front of the camera. The focus and iris settings of the lens should not have to be changed. Notify your AI if you believe that these settings are incorrect.

3. Position yourselves (re-aiming the camera if necessary) so that your faces fill the screen. Then reach over, hold down the ALT key, and hit the **Print Screen** button near the right end of the top row of keys on your keyboard. (This actually makes a copy of the screen, rather than printing anything.)

4. Now, open **Word 2003**. Click on **Edit → Paste** (upper left corner) to insert the image that was copied using the **Print Screen** command. (Please do NOT
change any of the computer or display settings in an attempt to make the image larger. Such changes may interfere with your analysis program.) Type your names below the image.

5. Click on File → Print icon on the top bar of Word to print your picture on one of the two Dell printers in the center of the Lab room. Each member of your team should include this picture in your Lab notebook. (Extra copies to take home, or to send your grandmother, are allowed.)

Stop and Think – What is a digital image?

Before trying to capture a video in the computer, let’s be sure that we understand what the moving image on a television screen actually consists of. It is a series of individual stationary, or still, pictures, appearing at a rate of 30 pictures, or frames, a second. Standard movie films consist of strips of such still pictures, recorded photographically at a slightly lower frame rate.

Digital computers, and hence our electronic imaging systems, work only in quantized units. Your camera divides the area that it sees into 307,200 pixels, arranged into a grid 640 cells wide by 480 cells high. You will see later that VideoPoint measures x- and y-positions with twice this resolution, dividing the x-direction into 640 integer steps and the y-direction into 480 steps. In either case, a 1-step by 1-step cell is called a pixel, for “picture element.”

To determine the coordinates of an object in an image frame using VideoPoint, we just position the cursor over the object, and the system will count the pixel rows and columns to get to the location of the cursor, starting at the lower left of the image on the screen. Then, if we know how many pixels correspond to a meter long object, we can calculate real distances from the pixel counts. This is called “scaling the image.” We will return to this shortly.

With real distances known from scaling the images, and with the time interval between two chosen frames also known (a multiple of 1/30 sec, say), we can easily calculate such things as velocities and accelerations of moving objects in our videos.

Note that the system reports locations rounded to the nearest integer pixel count. As a result, no position measurement can be known more accurately than within ± 0.5 pixel spacing, or to within ± 1/2 of whatever distance is equivalent to one pixel in real units (mm, meters, etc.).

B. Physics Background

In this Lab you will analyze the trajectory of a bouncing ball. The ball will be accelerated by gravity in the –y direction, but not in the x direction. Assuming that only gravitational forces are significant, the ball's motion should obey the equations
\[ x = x_0 + v_{0x} t , \quad (1) \]
\[ y = y_0 + v_{0y} t - \frac{1}{2} g t^2 , \quad (2) \]
\[ y = y_0 - x_0 \frac{v_{0y}}{v_{0x}} - g \frac{x_0^2}{2 v_{0x}^2} + x \left( \frac{v_{0y}}{v_{0x}} + g \frac{x_0}{2 v_{0x}^2} \right) - g \frac{x^2}{2 v_{0x}^2} . \quad (3) \]

In this experiment, a golf ball rolls down a fixed rail (the “launcher”). After it leaves the launcher it falls freely, bouncing at least twice on the table top. The camera takes a series of pictures at fixed time intervals between the first and second bounces, when the ball is moving freely. By measuring the position of the ball in each picture, you can test equations (1) and (2).

C. Acquiring the Data

Open VideoPoint Capture and use the Preview Screen to

1. Aim the camera, and check the lens focus and aperture setting.
2. Get a meter stick from the center of the room, and place it with its support bracket against the black backdrop. Verify that the launching rail is the same distance from the backdrop as is the meter stick. Remove the meter stick. You may have to share meter sticks with other groups.
3. Make a few trial runs, adjusting the launcher as necessary for the camera to catch one full bounce.
4. Set the frame rate to 30 frames per second, using Edit → Preferences → Capture Settings. Then, in the tab Output Settings, be sure the box next to Re-Compress When Saving is NOT checked. You must do this each time you (re)open VideoPoint Capture.
Make an Actual Movie of the Bouncing Ball

1. Start recording by clicking on the Record button.
2. Start the ball rolling down the launcher, and let it complete one full bounce.
3. Hit the Esc button on your keyboard to stop recording. (The Stop button on the screen doesn't always stop the recording quickly.)
4. Note: Although you don't need to rush things, don't record too much “dead air” before and after the actual experiment – it just ties up computer memory.
5. If you need to remake your video, click on the File menu (upper left) and then on New Capture (and don’t Keep/Save the bad video). Or, click the <<Record button in the lower left. Or, you can quit and restart VideoPoint Capture.

Viewing Your Video

After VideoPoint Capture takes a few seconds to organize your video, it displays the first frame of your movie in an EDITING window. Note that you can:

1. Play the movie by clicking on the little triangle at the lower left. Watch the progress as indicated by the moving “progress button” below the image. (Clicking on the triangle while the movie is playing will stop it at whatever frame it has reached.)
2. Jump to any frame by manually moving the progress button with your cursor.
3. Single-step from one frame to the next by clicking on the left- and right-arrow buttons in the lower right corner.
Each of you should spend some time playing with the **EDITING** screen controls, to understand their functions and to get a “feel” for the fact that a video or movie is really only a sequence of still pictures.

**Editing Your Video**

In general, your original video will contain more frames than you will want to use for analysis. Today, we want to analyze the ball's motion only between two consecutive bounces off the table.

To get rid of the unnecessary frames at the beginning and end of your video:

1. Use the progress and single-step buttons to choose the first frame after the ball has bounced from the table.
2. Click on the **First** button. All of the earlier frames are eliminated.
3. Move the video back to the last frame before the ball bounces again. Then click on **Last**. All of the later frames are eliminated, and your video contains just one bounce.
4. Click on **Keep** to save the file (or click on **File**, and then **New Capture** to discard the data and record a new movie).

**Naming and Saving Your VideoPoint Capture File**

There is a folder called **Student Data** on your **Desktop** in which you should store all of your data and analysis files.

To save your video,

1. Click on the **Save** button on the editing screen.
2. Enter a name with a **.mov** extension in the window **Save Movie File as**.
3. Click **Save**.
4. You are done with the program **VideoPoint Capture** for now. If you **Exit** and restart it later, you will have to reinitialize the frame rate and uncheck the **Re-Compress** box.
D. Digitizing the Ball’s Trajectory Using VideoPoint

Click the VideoPoint icon on your Desktop to open this program. If you see an information screen titled About VideoPoint, just click on the little x at the top right to make it disappear. One the next popup window, click Open Movie, and click on the movie that you saved in Student Data. In the Number of Points window which then appears, click OK to 1, since there is only one object that we want to analyze (the bouncing ball).

Your movie should now appear in a VideoPoint window, that shows the first frame of your edited video, with your file name appearing in its title bar. Two other windows pop up also, Table and Coordinate Systems, which may be behind the movie window. The movie window shows one frame at a time, whose number, and the total number of frames are given in the upper right corner.

Confirm that you can step through your movie, using the double arrows at the lower right. If the ball is not visible in all frames, or the movie includes more than a single arch, you should go back and make a new movie.

Digitizing Coordinates of the Bouncing Ball

The movie window is where you will "pick off" the coordinates of the golf ball's position in each frame. Note the yellow coordinate axes on the screen, and note that the cursor changes to a cross-hair pointing device when you move it into the image area. Finally, note that both the time of the frame and the x- and y-coordinates of the cursor are shown at the lower left of the movie window (with even values, equal to twice the pixel coordinates).
To record your positional data,

1. Go to the first frame of your edited movie.
2. Position the cursor over the image of the golf ball, and click your left mouse button.
3. Note that the movie advances automatically to the next frame. (If it doesn't, go the Options menu and put a check mark next to the Auto Frame Advance option.)
4. Click on the image of the golf ball for several more frames. Pause to turn on the Edit → Leave/Hide Trails option, and note that all the point that you have digitized are now shown, as well as all frames being superimposed.
5. Continue clicking on the image of the golf ball until you have recorded its position in all frames of your movie.
6. If you made a mistake in positioning your mouse in a particular frame, you may want to correct this. Go to the Coordinate Systems window and highlight the row labeled Point S1. This changes the symbol of the digitized point in the active frame to two concentric circles. If this is not the point you wish to change, go to the frame that contains the point in question. Then, while holding down the left button on the mouse, move the location circle to the new, corrected, position. Releasing the mouse button completes the change, and enters the corrected coordinates into the data table. It may be easier to first move the cursor to a very “wrong” position, and then make the “right” measurement.

The Table window now contains a list of your digitized points. It is prudent to save your work via File → Save As) to Student Data. VideoPoint will create a .vpt file for this.

VideoPoint includes various options for graphing and fitting curves to data. While you are free to try these out, we recommend using Excel for this purpose. The Appendix gives advice on how VideoPoint could be used instead.

E. Using Excel for the Data Analysis

Spreadsheet programs are powerful tools for data analysis, in finance and other fields as well as in science and engineering. Our version, Excel 2003 with includes extensions generated by an academic project, Workshop Physics (WP), to allow easier generation of graphs from spreadsheet data.
Start Excel to obtain a new, blank worksheet. To transfer your digitized data from VideoPoint, you will “cut and paste”. Back in VideoPoint, highlight all the data in the time column, and click Edit \(\rightarrow\) Copy Data. In Excel, right click on cell A2, and then click on Paste. Type a column label in cell A1. This label will later appear on your plots.

Similarly, highlight the two columns of your \(x\) and \(y\) data in the VideoPoint Table, then right click on cell B2 and click Paste. Add column labels in cells B1 and C1.

To make a graph in Excel with WPTools, you have to identify what you want plotted:

1. First, “swipe” your cursor across the data you want to plot on the horizontal axis. (For example, swipe across the time values.)
2. Then, while holding down the Ctrl key, swipe across the corresponding data you want for the vertical axis (say, the \(y\) values).
3. In the WP Standard bar click on the Scatter Plot icon to generate the plot.

A window should appear on your .xls sheet showing a plot of \(y\) vs. \(t\). Create plots of \(x\) vs. \(t\) and \(y\) vs. \(x\) in the same manner. These plots use your column labels.

You can now address the main issue of this Lab: Does the bouncing golf ball obey equations (1)-(3)? To do this, you will fit curves to your graphs, and thereby determine experimental values for \(x_0, y_0, v_{0x}, v_{0y}\) and \(g\), as well as estimates of the accuracy of these measurements.

First consider eq. (1) using your plot of \(x\) vs. \(t\). This is a linear equation, but in this case it’s best to try a cubic fit to learn if the data is actually linear.

1. Click on one of the data points of your \(x\) vs. \(t\) graph, to select and highlight the points plotted.
2. Click the Polynomial Fit icon in the WP Standard bar and choose Order 3 to create the fitted function. We usually recommend that you choose the order to be one higher than that you believe describes that data: thus, but in this Lab its better to choose order 3 for supposedly linear data. Several boxes describing the fit should appear on your graph window. [If not, go to WPTools / Preferences and make sure that the options for displaying fit equations and statistics on the plot are both checked. If not, check them, and redo the plot.]
3. The cubic fit is of the form \(x(t) = a_0 + a_1 t + a_2 t^2 + a_3 t^3\).
4. Note the value for \(\sigma\) (lower-case Greek letter sigma). This is the computer's estimate for how far a typical data point deviates from the fitted curve.
Does the value of $\sigma$ seem reasonable? You should comment on the magnitude of the typical deviations, and on possible causes, in your notebook. If $\sigma$ is too large, you should redigitize your images, or take a new movie.

5. Note also the values for $\text{SE}(a_0)$, $\text{SE}(a_1)$, $\text{SE}(a_2)$, and $\text{SE}(a_3)$. These are values of what are called the "standard errors" in the values which the computer calculated for $a_0$, $a_1$, $a_2$, and $a_3$. These are the computer's estimates for how precisely your data determine the fit parameters, given the "jitter" of the data about the curve. A discussion of the algorithm used to make these standard error estimates is given in Appendix D of the Lab Manual. If eq. (1) is indeed a good description of the data for $x$ vs. $t$, then parameters $a_2$ and $a_3$ should equal 0 to within the uncertainties $\text{SE}(a_2)$, and $\text{SE}(a_3)$. That is, if $a_2$ or $a_3$ differ from zero by more than 3 times $\text{SE}(a_2)$ or $\text{SE}(a_3)$, respectively, then it may be that eq. (1) is not a good description of the data. This is a very powerful feature of the data analysis, which gives a clue as to whether or not the theoretical explanation of the data is valid.

6. If you are convinced that eq. (1) is a good description of the data in the $x$ vs. $t$ plot, you can consider Excel's value for $a_1$ and $\text{SE}(a_1)$ to be your physics result for the value of $v_{ox}$ and the estimated error in that value (still in units of pixels/sec, of course, since you haven't yet converted pixels to meters.) Record your result for $v_{ox}$ in your lab book, and calculate the relative precision, $\text{SE}(a_1)/a_1$.

Make similar analyses of your plots of $y$ vs. $t$ and $y$ vs. $x$, using polynomial fits of order 4 even though the physics expectation is that these data should be quadratic functions. Of particular interest are the values (and error estimates) of parameters $a_2$ from these fits, since they are proportional to the acceleration $g$ of gravity, according to equations (2) and (3).

A Common Problem

Did your graph of $x$ vs. $t$ have some curvature, rather than looking like a straight line as implied by eq. (1)? Did your fit to $y$ vs. $t$ result in parameters $a_3$ or $a_4$ that differed from zero by more than 3 times $\text{SE}(a_3)$ or $\text{SE}(a_4)$, respectively?

A common reason for this is that the plane of the trajectory of the golf ball was not perpendicular to the optical axis of the camera. Denote the horizontal angle between the optical axis and the perpendicular to the plane of the trajectory as $\theta_x$ in radians, and the vertical angle between the optical axis and the perpendicular to the plane of the trajectory as $\theta_y$ in radians. Then, if parameter $a_3$ in the fit $x$ vs. $t$ and/or the parameter $a_4$ in the fit $y$ vs. $t$ is significantly different from zero, the angle $\theta_y$ is significantly different from zero. If the angle $\theta_x$ is significantly different from zero, this affects the values of the parameters $a_2$ in the fit to $x$ vs. $t$ and the parameter $a_3$ in the fit to $y$ vs. $t$.

A consequence of this is that your measurement of $g$ via the $y$ vs. $t$ plot has a systematic error roughly given by
\[ \frac{\Delta g}{g} \approx \frac{\theta_y}{2} + \frac{\theta_x}{2} - \frac{2v_{0y}v_{0y}}{gD}\theta_x. \] (4)

This effect could well be a major source of error in your measurement of \( g \), so you may wish to make new movies of the bouncing ball until you get one with values of \( a_2 \) and \( a_3 \) in the fit to \( x \) vs. \( t \) that are zero to within 2-3 times \( \text{SE}(a_2) \) and \( \text{SE}(a_3) \), respectively, and the values of \( a_3 \) and \( a_4 \) in the fit to \( y \) vs. \( t \) are zero to within 2-3 times \( \text{SE}(a_3) \) and \( \text{SE}(a_4) \), respectively. You may need to adjust to angle of the camera slightly, and you may need to take greater care as to the direction in which the ball is launched.

Strategy: If you think \( \theta_y \) is nonzero, adjust the vertical angle of the camera until your analysis give values for \( a_3 \) in the fit to \( x \) vs. \( t \) that are zero to within 3-4 times \( \text{SE}(a_3) \), and values for \( a_4 \) in the fit to \( y \) vs. \( t \) that are zero to within 3-4 times \( \text{SE}(a_4) \). Then, adjust the horizontal angle of the camera, and the horizontal angle of the launcher, until the values for \( a_2 \) in the fit to \( x \) vs. \( t \) that are zero to within 3-4 times \( \text{SE}(a_2) \), and values for \( a_3 \) in the fit to \( y \) vs. \( t \) that are zero to within 3-4 times \( \text{SE}(a_3) \).

This may be time consuming. If it proves difficult to achieve the desired results, proceed to step F before you run out of time to complete the Lab.

F. Scaling the Pixels

We have now to determine how many pixels in our picture correspond to one meter in the real world. We will do this by measuring how long a meter stick was in our video, as measured in pixels. The resulting value for our conversion factor (pixels per meter, or the inverse, meters per pixel) will allow us to convert any measurement from pixels to meters (or pixels/sec to meters/sec, etc.).

Our conversion factor will have some error, which we can estimate based on the pixel quantization error, plus a “guesstimate” as to how reproducibly we can position our cursor on the ends of the meter stick. Once we know the conversion factor, and its estimated error, we can use it to convert all of our measured \( x \)- and \( y \)-positions to meters from the origin, rather than pixels. But the conversions will all involve the factor, which has some error associated. This is a systematic error, since it affects all measurements equally.

If VideoPoint Capture is not still running, restart it (and remember to initialize the frame rate and uncheck the Re-Compress box). Take a short movie with the meter stick vertical in the center of the frame, and another with it horizontal. Remember to place the meter stick as far from the backdrop as is the launcher rail.

Use VideoPoint to analyze these movies. Move the cursor manually to either end of the meter stick (or the 10- and 90-cm positions), and note the pixel coordinates at the two position, from the live display at the lower left corner of the movie screen. Calculate the distance between the two points, in pixels. Using the distance in pixels, calculate your movie’s scale factor, \( F_x \) (or \( F_y \)), in units of pixels per meter. Use this to convert the
relevant fit values from your three plots into meters (or m/s, or m/s², etc.) to deduce the acceleration of the golf ball in m/sec² by two methods. Note the result in your lab book.

*Are your answers close to the expected value of g?* What effects might systematically bias your answer away from 9.8 m/s²?

Now let's consider what is the accuracy with which your measurements determine a value for g. If the uncertainty in g is called \( \Delta g \), then the fractional, or relative, uncertainty in g is defined as \( \frac{\Delta g}{g} \).

When you estimate the uncertainty in your determination of g, you should use both the computer's estimate of the effects of random error, \( \text{SE}(2) \), and your estimate of the uncertainty in the conversion factor \( F_x \) and \( F_y \) from pixels to meters. That is, for the measurement using the \( y \) vs. \( t \) data,

\[
\frac{\Delta g}{g} = \sqrt{\left( \frac{\text{SE} \ (a_2)}{a_2} \right)^2 + \left( \frac{\Delta F_y}{F_y} \right)^2},
\]

where \( F_y \) is your \( y \) scale factor. It is up to you to estimate a value for \( \Delta F_x \) and \( \Delta F_y \), perhaps by repeated trials. Taking responsibility for estimating the accuracy with which you make a measurement is not easy, but you have to do it. Take time to think it through!

Similarly, the estimate for the relative uncertainty on \( v_{0x} \) as determined from the \( x \) vs. \( t \) plot is

\[
\frac{\Delta v_{0x}}{v_{0x}} = \sqrt{\left( \frac{\text{SE} \ (a_1)}{a_1} \right)^2 + \left( \frac{\Delta F_x}{F_x} \right)^2},
\]

and the relative uncertainty on g as determined from the plot of \( y \) vs. \( x \) is

\[
\frac{\Delta g}{g} = \sqrt{\left( \frac{\text{SE} \ (a_2)}{a_2} \right)^2 + 4 \left( \frac{\Delta v_{0x}}{v_{0x}} \right)^2}.
\]

Some discussion of the calculus of propagation of errors is given in Appendix B.8 of the Lab Manual.

**Record your final results for g and for \( \Delta g \).**

Note any comments you might have on the reliability of your conclusions, and on a comparison of your results with the accepted value for g, namely 9.80 m/sec².
Appendix: Using VideoPoint for Data Analysis

Graphing Your Data

To use VideoPoint to make graphs, first click on the View -> New Graph menu item. For each graph, you must tell the system which variable you want plotted on the x-axis, and which on the y-axis. Normally, you will want either time or x-position to run horizontally, and x- or y-position, velocity, or acceleration to run vertically.

Let’s make and print out some graphs. Start with an XY graph. Choose Point S1 / x / Position for the Horizontal Axis, and S1 / y / Position for the vertical axis. Note that, if you go back to the Movie window and advance through the frames, a circle moves on the graph to indicate which of the points plotted corresponds to the movie frame currently visible.

To print a graph, first make its screen active by clicking anywhere on it. (The title bar of the graph will be colored blue after your click.) Then click on the File -> Print menu bar option, and click on Print and OK when you are asked to confirm your request. If you maximize the size of the graph window before printing, your printed graph will be larger.

You can also make a printout of any one of the frames of your video, simply by printing when the movie window is selected.

If you need a printout of your data table, first be sure to first maximize the table window by clicking on the middle one of the three boxes at the right end of the Table title bar. Then issue the print commands. When you want to make the table small again, just click on the middle box, as before. (If your table is very long, you may have to print more than one time, scrolling vertically to change which data lines are presented each time.)

Physics Discussion

Print out and think about the following graphs. Each of you should have your own copy of the group’s printouts, and note your own conclusions on your own plots.

1. Do the plots of x-position, velocity, and acceleration all confirm that the golf ball is subject to no horizontal force?
2. Does a plot of y-position vs. time look like you expected? (What is that?)
3. What does a plot of y-velocity vs. time look like? What does that show?
4. What about a plot of $y$-acceleration vs. time?

You should know that we expect to see a constant, negative, acceleration of the golf ball in the $y$-direction. Numerically, we expect that the acceleration of the golf ball will be $g$, which is approximately equal to 9.80 m/sec$^2$. But we have yet to scale our movie, in order to find the conversion factor between pixels and meters.

Before we scale the movie, let's look at our results in terms of pixels, and take a look at how accurate those results seem to be.

**Final Analysis – Fitting Your Data; Looking at Data "Jitter"**

Now for some more quantitative analysis. First, let's fit a quadratic curve to $y$ as a function of time. The computer can show us the quadratic function that "comes closest" to passing through all of the data points on our $y$ vs. $t$ plot.

To do this, go to your graph of $y$-position vs. time, and then click on the red F (for Fit) button near the upper right hand corner. A dialog box will appear. Select the Polynomial option, and then choose Order 2, and click on Apply. VideoPoint's best-fit line should appear on the graph.

At the top of the graph is the algebraic function resulting from the plotted fit. (Here, $x$ refers to whatever is the horizontal variable on the graph, not to our $x$ coordinate. Also, you should ignore the computer's $R^2$ (R-squared) parameter. It is simply one of several statistical measure of the goodness of the fit, and VideoPoint often calculates it incorrectly.)

The number multiplying the squared term in the fit corresponds to the "$1/2 \cdot g$" factor in equation (2). If we multiply our number by 2, that gives our experimental value for $g$, in units of pixels/sec$^2$.

Before moving on to scale the movie, and get $g$ in m/sec$^2$, let's look at how closely our data follows the computer's “best fit” curve.

**Zooming in VideoPoint; Looking at Data “Jitter”**

Maximize your plot of $y$ vs. $t$. Probably all of the points lie close to the curve, but how close?
"Magnify" a region of your VideoPoint plot, by “zooming in” on it with the following steps:

5. While holding down the Ctrl (Control) key of your keyboard, hold down on the left mouse button and use the cursor to draw a rectangular box around a region of interest containing one of your data points. The graph then shows only that region, in a magnified view.

6. If you want to magnify some more, do it again. (But if you magnify too much, the fit line may disappear, and you'll have to start over by returning to the unmagnified graph.)

7. When you want to return to your original unmagnified view, just hold down on the Ctrl key and double-click with the left button of your mouse.

Use the zooming feature to look at several points of your graph, and to judge how far the points are vertically away from the best-fit curve. **Record your results, and calculate the average of the magnitudes of the deviations that you found.** [WARNING – after a “zoom,” the scales on VideoPoint's graphs may not be quite what they seem. Often, there is an additional decimal place which is not shown on the screen's axis labels. To correct this, you can double-click on the axis, and delete the extra digit to cure the problem. For now, it is easier to use the cursor readout at the lower left corner of the graph to estimate the differences between your data point and the nearby curve.]

The average deviation which you have calculated is an estimate for how much an individual measurement varies from the “true” value indicated by the curve. It includes the random ± 0.5 pixel “quantization error,” plus any inaccuracies you introduced in picking off your points.

**Storing Your VideoPoint File**

First, click on File → Save As in the VideoPoint menu bar. As before, use the up arrow and double-clicking to cause your section’s folder identification to appear in the Save in: box at the top of the dialog box which appears. It will be convenient to use the same name as the one you gave the video file which you saved at the end of the VideoPoint Capture activities. This name should be visible at the top of the movie screen, if you have forgotten it.

If you use Windows Explorer to look at the contents of your section’s data folder, you will see that there are actually three files associated with any movie that you have analyzed. A large file with the extension .mov contains the actual movie. A small file, having the same name with the extension .mov.#res added comes along with the movie
file. The VideoPoint file .vpt is also a small one. It has whatever name you gave it, but can be used only if the movie file is also available on your computer.
PRELAB Problems for Lab#1: Encountering the Equipment; Motion in Two Dimensions

1. Assume that in a digital image there are 600 lines and 800 columns (typical for some computer display screens). Each point in the image lying at the intersection of a line and a column is called a picture element, or “pixel.” Each pixel has its own brightness and color. The intensity of each of the three primary colors at each pixel may be described by an integer number, lying between 0 and 255. Each number takes 8 digital bits, or 1 “byte,” to define.

(a) How many pixels are there in the image?
(b) How many bytes of computer memory are required to record the image?
(c) If a video or movie consists of a series of 30 such images every second, how many bytes of information must be transmitted every second in order to display the movie? How many bits per second? (This is what sets the electrical engineer's design specification for a television system.)

2. Isaac Newton is said to have considered the motion of an apple falling from the tree in thinking about gravitational forces. If we look at the apple's vertical motion, starting from the instant when it is released from rest, the distance it falls increases with time according to the formula for uniform acceleration,

\[ s = \frac{1}{2} g t^2. \]

Galileo, who died the year Newton was born, studied motion under uniform acceleration, but did not have Newton's mathematics. He concluded that

Starting from rest, distances traveled in successive equal increments of time are in the proportions 1 : 3 : 5 : 7 : ........

(a) Using the formula \( s = \frac{1}{2} g t^2 \), calculate the vertical distances traveled by a ball falling from rest after 0.1, 0.2, 0.3, 0.4, and 0.5 seconds. (To honor Newton's heritage, let's use English units and take \( g = 32 \text{ ft/ sec}^2 \).)

(b) Show that your results are consistent with Galileo's description.

If you are intrigued by this result, you might want to prove that Newton's result produces Galileo's rule, for any set of equal time increments. Hint: think about the quantity \((N + 1) \Delta T)^2 - [N \Delta T)^2.\)
Appendix A

Data Analysis with Excel

Computers are used for data analysis in any modern physics laboratory, and the Physics 103 lab is no exception. We have built our data analysis system around the program Excel, which is widely used on and off campus. We’ve added some Workshop Physics (WP) tools to make graphing data easier, and to let you do regression calculations with uncertainties, but otherwise we are using the standard, off-the-shelf software.¹

If you are already familiar with Excel, great! If not, we’ll give brief instructions here. Like any software, it can be confusing at first, so don’t hesitate to ask your instructors and your fellow students for help. Play around with the program a bit to get comfortable with it.

A.1 Starting Things Up

- If the computer isn’t already on, turn it on and wait for it to boot up.
- If the Physics 103 window isn’t already open, double click on the Physics 103 icon to open it
- Double click on Excel with WPtools (look for the X logo) to get the program running.

A.2 Entering Data: a Simple Example¹

When Excel is started up, you need to open a spreadsheet to work in. If you are asked if you want to reopen WPtools, click No. Then go to File→New and click on OK to open a new Workbook. (If you wanted to open a pre-existing spreadsheet, you would use the File→Open menu command; if you want to save the new spreadsheet, use the File→Save menu command. Since we’ll be working with fairly small datasets, neither of these is really necessary for your lab work.)

Suppose you wish to record some \((x, y)\) data pairs in two columns of a spreadsheet. Go to Excel, and start entering the data in the upper left most cell (called A1). To do this, move the cursor to this cell and click on it with the left mouse button. Enter the first \(x\) data value

¹Some online documentation for WPtools is at http://physics.dickinson.edu/~wp_web/wp_resources/Documentation.html
¹¹Note: Menu commands are described as follows: File→Open means move the cursor to the word File on the line near the top of the screen, press and hold the left mouse button, drag the cursor down to the word Open, and release the button.
here, pressing Return when you are done. The cell below it (called A2) will automatically be selected next; enter the second x data value here. Work down the first data column in this way. If you need to go back and correct any of the numbers, simply move the cursor with the mouse, click on the relevant cell, and re-enter the number.

Once you’ve entered the first column of numbers, move the cursor to the top cell of the second column (cell B1) and click the left button to select it. Enter the first y data value. Press Return/Enter, and enter subsequent y data in the rest of the cells.

A.3 Calculations in Excel

Now that your two columns of data are in the computer, select them. Do this by moving the cursor to the top left cell, pressing and holding the left mouse button, dragging the cursor to the lowest filled cell in the second column, and then releasing the mouse button. The block of numbers you entered will now be “selected”, indicated by a blue-grey color.

Go to the WPtools pull-down menu and select Linear Fit. Immediately Excel will display a plot of your data, along with the values and uncertainties of the best-fit line. Print out a copy of the results if desired.²

Sometimes you will want to transform your raw data in some way before plotting it. For example, you may have entered two columns of data as above, but you want to convert the y values from inches to meters. This is where a spreadsheet program becomes really handy. Select a blank cell somewhere on the sheet (cell C1 would be a good place). Instead of entering a number, enter the formula ‘=0.0254*B1’, and press Return. Excel will display the expected numerical value in cell C1, and it will also remember the formula. This is useful for two reasons, first, if you change the value in B1, then number in C1 will be automatically updated. Second, you can copy the formula in C1 to other cells, transforming the rest of column B using the same formula. To do this, first select cell C1. The cell becomes outlined, and note that there is a little square in the lower right corner of the outline. Move the cursor to this square, push and hold the left mouse button, drag the cursor down several cells, and release the mouse button. Voila! Excel will use the same formula to multiply all the cells in column B by 0.0254.

Excel can do much more complicated arithmetic. For example, you could use the formula =sqrt(A1) * B1 to take the square root of the values of cells in column A, multiply them by the values in column B, and put the result in some other column.

You might also want to take differences between the successive items in your data list. If you type into cell C2 the formula =B2-B1, and then use the little square to fill this formula into the cells B3, B4, etc., then you will obtain the differences in column C.

If you do a transformation like this, and then you want to do a plot or a curve fit, the columns of data you want to plot may not be adjacent to each other. No problem. Say you want to plot cells A1-A10 on the horizontal axis and cells C1-C10 on the vertical axis. First

²You must first “grab” the plot by left-clicking on an open area inside it. If the plot legends are obscuring the graph, drag them aside with the mouse. Your can add labels to your plot using the Edit labels option on the WPtools menu bar.
select A1-A10. (Go to cell A1, hold down the left button, drag the cursor to A10, then release the mouse button). Then hold down the Ctrl key and select C1-C10. Now both cell groups A1-A10 and C1-C10 will be selected, but not B1-B10. Run the WPTools→LinearFit routine, and you will get the plot you want.

A.4 Accumulating Values via Excel Tricks

There will be times in the Physics 103 lab when you want to accumulate sums of a series of values. For example, you might have measured a series of time intervals,

\[
\Delta t_1 = \text{interval between event 1 and event 2,} \\
\Delta t_2 = \text{interval between event 2 and event 3,} \\
\Delta t_3 = \text{interval between event 3 and event 4,} \\
\text{etc.}
\]

You may wish to convert these into a continuous time scale. In other words, you may want to declare that \( t = 0 \) at the time of event 1, and then find

\[
\begin{align*}
t & \text{of event 2} = \Delta t_1, \\
t & \text{of event 3} = \Delta t_1 + \Delta t_2, \\
t & \text{of event 4} = \Delta t_1 + \Delta t_2 + \Delta t_3, \\
\text{etc.}
\end{align*}
\]

This is easy to do. Say that \( \Delta t_1, \Delta t_2, \text{etc.} \), are in cells A1, A2, etc., and you want to put the accumulated times in column B. First put a 0 in cell B1 (since \( t = 0 \) for the first event). Then go to cell B2 and enter the formula =SUM($A$1:A1). The SUM function simply adds up the cells in the range specified.

The usefulness of the $ notation becomes apparent when you want to calculate the rest of the times. Select B2, move the cursor to the square in the lower righthand corner of the cell border, press and hold the left mouse button, drag the cursor down several cells, and release the button. The cells in column B are now filled with SUM functions, but in a special way: The $A$1 in the SUM function call remains the same in all the cells (because of the $), but the second part of the function call changes from A1 to A2 to A3, ... In other words, cell B3 now reads =SUM($A$1:A2), cell B4 reads =SUM($A$1:A3), and so on. These are exactly the formulae we want for the event time calculations, so column B is now filled with calculated values of \( t \).

A.5 Further Notes about Workshop Physics Routines

• Use the WPtools→Polynomial Fit menu command, and set Order=2 to fit lines of the form \( y = c_0 + c_1 x + c_2 x^2 \).
• If you enter non-numerical text in the cell above each column of data, it will be used to label the horizontal and vertical axes on the plot.
• The fitting routines always use the first selected column for the horizontal (x) points, and the second selected column for the vertical (y) points.

• Empty rows are usually ignored (but partially-empty rows may corrupt the fit).

• To delete a plot, select it (move cursor to it and click once), then press the Delete key. To delete a column of the sheet, select the entire column (by clicking on the letter at the top) and use Edit→Delete.

• If data are modified after running a fit, the associated plot will be automatically updated, but the fit parameters will not be re-calculated. Usually it is best to delete both the old plot and fit parameters after updating data.
Appendix B

Estimation of Errors

While the subject of error analysis can become quite elaborate, we first emphasize a basic but quite useful strategy, discussed in secs. B.1-2. Then, we distinguish between random (or statistical uncertainties and systematic uncertainties in sec. B.3. Random uncertainties follow the famous bell curve, as sketched in secs. B.4-5. The important distinction between the uncertainty on a single measurement, and the uncertainty on the average of many repeated measurements is reviewed in secs. B.7-7. The subject of propagation of errors on measured quantities to the error on a function of those quantities is discussed in sec. B.8.

B.1 67% Confidence

Whenever we make a measurement of some value \( v \), we would also like to be able to say that with 2/3 probability the value lies in the interval \([v - \sigma, v + \sigma]\). We will call \( \sigma \) the uncertainty or error on the measurement. That is, if we repeated the measurement a very large number of times, in about two thirds of those measurements the value \( v \) would be in the interval stated.

B.2 A Simple Approach

Repeat any measurement three times, obtaining a set of values \( \{v_i\}, i = 1, 2, 3 \). Report the average (mean),

\[
\bar{v} = \frac{1}{N} \sum_{i=1}^{N} v_i \quad \text{(for } N = 3),
\]

as the best estimate of the true value of \( v \), and the uncertainty \( \sigma \) as

\[
\sigma = \frac{v_{\text{max}} - v_{\text{min}}}{2}.
\]

If you take more than three measurements, you can still implement this procedure with the aid of a histogram. Divide the range of observed values of \( v \) into 5-10 equal intervals (called bins). Located the bin that contains each measurement, and draw a box one unit high above that bin. Stack the boxes on top of one another if more than one measurement falls in a bin. To estimate the error, determine the interval in \( v \) that contains the central 2/3 of the measurements, i.e., the central 2/3 of the boxes you just drew, and report the error as 1/2 the length of this interval.
B.3 Random and Systematic Uncertainties

The uncertainty in a measurement of a physical quantity can be due to intrinsic random uncertainty (colloquially: error) as well as to systematic uncertainty.

Random uncertainties lead to difference in the values obtained on repetition of measurements. Systematic uncertainties cause the measurement to differ from its ideal value by the same amount for all repetitions of the measurement.

Random uncertainties can arise from vibrations of the components of a set-up driven by random thermal fluctuations, random noise in the electronics, and/or many other small but uncontrolled effects including quantum fluctuations.

In principle, the effect of random uncertainties can be made as small as desired by repetition of the measurements, such that the dominant uncertainty is due to systematic effects (which can only be reduced by designing a better measurement apparatus).

B.4 The Bell Curve

In many cases when a measurement is repeated a large number of times the distribution of values follows the bell curve, or Gaussian distribution:

\[ P(v) = \frac{e^{-(v-\mu)^2/2\sigma^2}}{\sqrt{2\pi}\sigma}, \]

where \( P(v)dv \) is the probability that a measurement is made in the interval \([v, v + dv]\), \( \mu \) is true value of the variable \( v \), and \( \sigma \) is the standard deviation or uncertainty in a single measurement of \( v \). See Figure B.1.

![Figure B.1: The probability distribution measurements of a quantity with true value \( \mu \) and Gaussian uncertainty \( \sigma \) of a single measurement. About 68% of the measurements would fall in the interval between \( \mu - \sigma \) and \( \mu + \sigma \), and 95% would fall in the interval \( \mu \pm 2\sigma \).](image-url)
Table B.1: The probability (or confidence) that a measurement of a Gaussian-distributed quantity falls in a specified interval about the mean.

<table>
<thead>
<tr>
<th>Interval</th>
<th>Confidence</th>
</tr>
</thead>
<tbody>
<tr>
<td>±σ</td>
<td>68%</td>
</tr>
<tr>
<td>±2σ</td>
<td>95%</td>
</tr>
<tr>
<td>±3σ</td>
<td>99.7%</td>
</tr>
<tr>
<td>±4σ</td>
<td>99.994%</td>
</tr>
</tbody>
</table>

measurements during these lab sessions, then 10,000 measurements will be taken in all. The Table tells us that if those measurements have purely Gaussian ‘errors’, then we expect one of those measurements to be more than 4σ from the mean.

B.5 Estimating Uncertainties When Large Numbers of Measurements Are Made

One can make better estimates of uncertainties if the measurements are repeated a larger number of times. If $N$ measurements are made of some quantity resulting in values $v_i$, $i = 1, \ldots, N$ then the mean is, of course,

$$\bar{v} = \frac{1}{N} \sum_{i=1}^{N} v_i,$$  \hspace{1cm} (B.4)

and the standard deviation of the measurements is

$$\sigma = \sqrt{\frac{1}{N - 1} \sum_{i=1}^{N} (v_i - \bar{v})^2}. \hspace{1cm} (B.5)$$

Calculus experts will recognize that the operation $(1/N) \sum_{i=1}^{N}$ becomes $\int P(v) \, dv$ in the limit of large $N$. Then, using the Gaussian probability distribution (B.3) one verifies that

$$\bar{v} = \langle v \rangle = \int_{-\infty}^{\infty} v P(v) \, dv, \hspace{1cm} \text{and} \hspace{1cm} \sigma^2 = \langle (v - \bar{v})^2 \rangle = \int_{-\infty}^{\infty} (v - \bar{v})^2 P(v) \, dv. \hspace{1cm} (B.6)$$

B.6 The Uncertainty on Mean of a Uniformly Distributed Quantity

Not all measurable quantities follow the Gaussian distribution. A simple example is a quantity with a uniform distribution, say with values $v$ equally probable over the interval $[a, b]$. It is clear that the average measurement would be $(a + b)/2$, but what is the uncertainty of the measurement? If we adopt the simple prescription advocated in secs. B.2 we would
report the uncertainty as \((b - a)/3\) since \(2/3\) of the time the measurement would fall in an interval \(2(b - a)/3\) long. If instead we use the calculus prescription for \(\sigma\) given in eq. (B.6) we find that

\[
\sigma = \frac{b - a}{\sqrt{12}} = \frac{b - a}{3.46},
\]

which result is often used by experts.

### B.7 The Uncertainty in the Mean

Thus far we have considered only the uncertainty or spread in measured values of some quantity \(v\). A related but different question is: what is the uncertainty on our best estimate of \(v\) (which is just the mean value of our measurements, \(\bar{v} = (1/N) \sum v_i\))?

The uncertainty on the mean \(\bar{v}\) is surely less that the uncertainty, \(\sigma\), on each measurement \(v_i\). Indeed, the uncertainty on the mean is given by

\[
\sigma_{\bar{v}} = \frac{\sigma}{\sqrt{N}},
\]

where \(\sigma\) is our estimate of the measurement error obtained from one of the methods sketched previously.

Appendix C illustrates eq. (B.8) using measurements of \(g\) from past Ph103 labs.

### B.8 The Uncertainty on a Function of Several Variables (Propagation of Error)

In many cases we are interested in estimating the uncertainty on a quantity \(f\) that is a function of measured quantities \(a, b, \ldots c\). If we know the functional form \(f = f(a, b, ..., c)\) we can estimate the uncertainty \(\sigma_f\) using some calculus. As a result of our measurements and the corresponding ‘error analysis’ we know the mean values of \(a, b, \ldots c\) and the error estimates \(\sigma_a, \sigma_b, \ldots \sigma_c\) of these means. Our best estimate of \(f\) is surely just \(f(a, b, ..., c)\) using the mean values.

To estimate the uncertainty on \(f\) we note that the change in \(f\) due to small changes in \(a, b, \ldots c\) is given by

\[
\Delta f = \frac{\partial f}{\partial a} \Delta a + \frac{\partial f}{\partial b} \Delta b + \ldots + \frac{\partial f}{\partial c} \Delta c.
\]

If we just averaged this expression we would get zero, since the ‘errors’ \(\Delta a, \ldots \Delta c\) are sometimes positive, sometimes negative, and average to zero. Rather, we square the expression for \(\Delta f\), and then average.

\[
\Delta f^2 = \left( \frac{\partial f}{\partial a} \right)^2 \Delta a^2 + \ldots + \left( \frac{\partial f}{\partial c} \right)^2 \Delta c^2 + \ldots + 2 \frac{\partial f}{\partial a} \frac{\partial f}{\partial c} \Delta a \Delta c + \ldots
\]

On average the terms with factors like \(\Delta a \Delta c\) average to zero (under the important assumption that parameters \(a, b, \ldots c\) are independent). We identify the average of the squares of
the changes relative to the mean values as the squares of the errors: \( \langle \Delta a^2 \rangle = \sigma_a^2 \), etc. This leads to the prescription

\[
\sigma_f^2 = \left( \frac{\partial f}{\partial a} \right)^2 \sigma_a^2 + \cdots + \left( \frac{\partial f}{\partial c} \right)^2 \sigma_c^2 + \cdots \quad (B.11)
\]

Some useful examples are

\[
f = a \pm b \pm \ldots \pm c \quad \Rightarrow \quad \sigma_f = \sqrt{\sigma_a^2 + \sigma_b^2 + \cdots + \sigma_c^2}, \quad (B.12)
\]

and

\[
f = a^l b^m \ldots c^n \quad \Rightarrow \quad \frac{\sigma_f}{f} = \sqrt{l^2 \left( \frac{\sigma_a}{a} \right)^2 + m^2 \left( \frac{\sigma_b}{b} \right)^2 + \cdots + n^2 \left( \frac{\sigma_c}{c} \right)^2}, \quad (B.13)
\]

where \( l, m \) and \( n \) are constants that may be negative.

For more detailed and rigorous analyses one can consult, for example:


Appendix C

Standard Deviation of the Mean of $g$

Suppose you make $N$ repeated measurements of a quantity $g$, such as the acceleration due to gravity. How well is the value of $g$ determined by these measurements?

For example, during the 2006 sessions of Ph103 Lab 6 a total of 37 different measurements of $g$ were made, as shown in the histogram Fig. C.1.

![Histogram of 37 measurements of $g$](image)

Figure C.1: Histogram of the values of $g$ measured in the 2006 Ph103 Lab 3. The horizontal axis is $g$, and the vertical axis is the number of times a value of $g$ was reported to lie with the range of $g$ corresponding to the width of a vertical bar.

A histogram is a graph containing $M$ vertical bars in which the height of a bar indicates the number of data points whose value falls within the corresponding “bin”, i.e., within the interval $[g_j - \Delta/2, g_j + \Delta/2]$, where $g_j, j = 1, M$ and the centers of the $M$ bins and $\Delta$ is the bin width. One can make a histogram of a data set $\{g_i\}$ using Excel/Tools/Data Analysis/Histogram. Enter the data $\{g_i\}$ in one column of an Excel spreadsheet. Click on the Input Range: box of the Histogram window; then click and hold the left mouse button on the first data point, and drag the mouse to the last data point to enter the cell addresses of the data. Click on Chart Output and then OK to create a basic histogram. If the number/spacing of “bins” chosen by Excel is awkward, fill a new column with a linear series of 5-10 steps that begins near the lowest $g_i$ and ends near the highest; create a new histogram with the Excel addresses of the first and last elements of the bin list in the box Bin Range.:
The mean value $\bar{g}$ is calculated according to

$$\bar{g} = \frac{\sum_{i=1}^{N} g_i}{N}, \quad \text{(C.1)}$$

and was found to be $\bar{g} = 939.5 \text{ cm/s}^2$ for the data shown in Fig. C.1.

The distribution of the value of $g$ is approximately Gaussian, and the standard deviation of this distribution is calculated according to

$$\sigma_g = \sqrt{\frac{\sum_{i=1}^{N} (g_i - \bar{g})^2}{N - 1}}, \quad \text{(C.2)}$$

with the result that $\sigma_g = 9.1 \text{ cm/s}^2$.

The standard deviation $\sigma_g$ is a good estimate of the uncertainty on a single measurement of $g$. However, after 37 measurements of $g$, the uncertainty on the mean value $\bar{g}$ is much smaller than $\sigma_g$.

An important result of statistical analysis is that the standard deviation (i.e., the uncertainty) of the mean of the $N$ measurements is related to the standard deviation of the distribution of those measurements by,

$$\sigma_{\bar{g}} = \frac{\sigma_g}{\sqrt{N}}. \quad \text{(C.3)}$$

For the data shown in Fig. C.1, where $N = 37$, we obtain

$$\sigma_{\bar{g}} = \frac{9.1}{\sqrt{37}} = 1.5 \text{ cm/s}^2. \quad \text{(C.4)}$$

That is, we can report the result of all 37 measurements of $g$ as

$$g = 979.5 \pm 1.5 \text{ cm/s}^2. \quad \text{(C.5)}$$

As a check that eq. (C.3) is valid, we can analyze the data another way. Namely, we can first calculate the means $\bar{g}_i$ for the 5 different sessions of Ph103 Lab 3. Then, we can make a histogram of these 5 values, as shown in Fig. C.2.

The mean of the 5 means is 979.6 cm/s$^2$, which is essentially identical to the mean of the 37 individual measurements of $g$. The standard deviation of the 5 means shown in Fig. C.2 is calculated to be 1.6 cm/s$^2$, which is essentially identical to the previous calculation (C.4) of the standard deviation of the mean.

**Concluding Remarks:** If $N$ were much larger than what we have here, the histogram C.1 would approach the Gaussian distribution (the bell-curve) shown in Appendix B. The peak in the histogram would be very close to the mean value $\bar{g}$ of the measurements, which represents the best estimate of $g$ from the data. The standard deviation $\sigma_g \approx \text{width}/2$ is a measure of the uncertainty of a single measurement,\(^1\) while $\sigma_g/\sqrt{N}$ is the uncertainty on the best estimate $\bar{g}$.

\(^1\)Strictly speaking, the full width at half maximum of a Gaussian distribution is $2.35\sigma_g$. 
Figure C.2: Histogram of the mean values of $g$ measured in the 5 sessions of Ph103 Lab 6 in 2006.
Appendix D

Polynomial Fits in WPtools

D.1 Polynomial Regression

In this technical Appendix we sketch the formalism used in the polynomial regression method for fitting data. This is a generalization of the method of linear regression.

We start with a set of data \((x_j, y_j)\), \(j = 1, \ldots, m\), and we wish to fit these data to the \(n\)th-order polynomial

\[
y(x) = \sum_{i=0}^{n} a_i x^i. \tag{D.1}
\]

In general each measurement \(y_j\) has a corresponding uncertainty \(\sigma_j\). That is, if the measurements were repeated many times at coordinate \(x_j\) the values of \(y_j\) would follow a gaussian distribution of standard deviation \(\sigma_j\). We indicate in sec. D.2 how the program WPtools proceeds in the absence of input data as to the \(\sigma_j\).

Because of the uncertainties in the measurements \(y_j\) we cannot expect to find the ideal values of the coefficients \(a_i\), but only a set of best estimates we will call \(\hat{a}_i\). However, we will also obtain estimates of the uncertainties in these best-fit parameters which we will label as \(\sigma_{\hat{a}_i}\).

The best-fit polynomial is then

\[
\hat{y}(x) = \sum_{i=0}^{n} \hat{a}_i x^i. \tag{D.2}
\]

The method to find the \(\hat{a}_i\) is called least-squares fitting as well as polynomial regression because we minimize the square of the deviations. We introduce the famous \textit{chi square}:

\[
\chi^2 = \sum_{j=1}^{m} \frac{[y_j - \hat{y}(x_j)]^2}{\sigma_j^2} = \sum_{j=1}^{m} \frac{(y_j - \sum_{i=0}^{n} \hat{a}_i x_j^i)^2}{\sigma_j^2}. \tag{D.3}
\]

Fact: \(\exp(-\chi^2/2)\) is the (un-normalized) probability distribution for observing a set of variables \(\{y_j(x_j)\}\) supposing the true relation of \(y\) to \(x\) is given by eq. (D.2).

A great insight is that \(\exp(-\chi^2/2)\) can be thought of another way. It is also the (un-normalized) probability distribution that the polynomial coefficients have values \(a_i\) when their best-fit values are \(\hat{a}_i\) with uncertainties due to the measurements \(\{y_j\}\). Expressing this in symbols,

\[
\exp(-\chi^2/2) = \text{const} \times \exp \left( - \sum_{k=0}^{n} \sum_{l=0}^{n} \frac{(a_k - \hat{a}_k)(a_l - \hat{a}_l)}{2\sigma_{kl}^2} \right), \tag{D.4}
\]
or equivalently

$$\chi^2/2 = \text{const} + \sum_{k=0}^{n} \sum_{l=0}^{n} \frac{(a_k - \hat{a}_k)(a_l - \hat{a}_l)}{2\sigma_{kl}^2}. \quad (D.5)$$

The uncertainty on $\hat{a}_k$ is $\sigma_{kk}$ in this notation. In eqs. (D.4) and (D.5) we have introduced the important concept that the uncertainties in the coefficients $\hat{a}_k$ are correlated. That is, the quantity $\sigma_{kl}^2$ is a measure of the probability that the values of $a_k$ and $a_l$ both have positive fluctuations at the same time. In fact, $\sigma_{kl}^2$ can be negative indicating that when $a_k$ has a positive fluctuation then $a_l$ has a correlated negative one.

One way to see the merit of minimizing the $\chi^2$ is as follows. According to eq. (D.5) the derivative of $\chi^2$ with respect to $a_k$ is

$$\frac{\partial \chi^2}{\partial a_k} = \sum_{l=0}^{n} \frac{a_l - \hat{a}_l}{\sigma_{kl}^2}, \quad (D.6)$$

so that all first derivatives of $\chi^2$ vanish when all $a_l = \hat{a}_l$. That is, $\chi^2$ is a minimum when the coefficients take on their best-fit values $\hat{a}_i$. A further benefit is obtained from the second derivatives:

$$\frac{\partial^2 \chi^2}{\partial a_k \partial a_l} = \frac{1}{\sigma_{kl}^2}. \quad (D.7)$$

In practice we evaluate the $\chi^2$ according to eq. (D.3) based on the measured data. Taking derivatives we find

$$\frac{\partial \chi^2}{\partial \hat{a}_k} = \sum_{j=1}^{m} \left( y_j - \sum_{i=0}^{n} \hat{a}_i x_j^i \right) \left( -x_j^k \right) = \sum_{i=0}^{n} \sum_{j=1}^{m} \frac{\hat{a}_i x_j^i x_j^k}{\sigma_j^2} - \sum_{j=1}^{m} \frac{y_j x_j^k}{\sigma_j^2}, \quad (D.8)$$

and

$$\frac{\partial^2 \chi^2}{\partial \hat{a}_k \partial \hat{a}_l} = \sum_{j=1}^{m} \frac{x_j^k x_j^l}{\sigma_j^2} \equiv M_{kl}. \quad (D.9)$$

To find the minimum $\chi^2$ we set all derivatives (D.8) to zero, leading to

$$\sum_{i=0}^{n} \sum_{j=1}^{m} \frac{x_j^i x_j^k}{\sigma_j^2} \hat{a}_i = \sum_{j=1}^{m} \frac{y_j x_j^i}{\sigma_j^2} \equiv V_k. \quad (D.10)$$

Using the matrix $M_{kl}$ introduced in eq. (D.9) this can be written as

$$\sum_{i=0}^{n} M_{ik} \hat{a}_i = V_k. \quad (D.11)$$

We then calculate the inverse matrix $M^{-1}$ and apply it to find the desired coefficients:

$$\hat{a}_k = \sum_{l=0}^{n} M^{-1}_{kl} V_l. \quad (D.12)$$

Comparing eqs. (D.7) and (D.9) we have

$$\frac{1}{\sigma_{kl}^2} = M_{kl}. \quad (D.13)$$

The uncertainty in best-fit coefficient $\hat{a}_i$ is then reported as

$$\sigma_{\hat{a}_i} = \sigma_{ii} = \frac{1}{\sqrt{M_{ii}}}. \quad (D.14)$$
D.2 Procedure When the $\sigma_j$ Are Not Known

This method can still be used even if the uncertainties $\sigma_j$ on the measurements $y_j$ are not known. When the functional form (D.1) correctly describes the data we claim that on average the minimum $\chi^2$ has value $m - n - 1$.\footnote{The whole fitting procedure does not make sense unless there are more data points ($m$) than parameters ($n + 1$) being fitted.} To take advantage of this remarkable result we suppose that all uncertainties $\sigma_j$ have a common value, $\sigma$. Then

$$\chi^2 = \sum_{j=1}^{m} \frac{[y_j - \hat{y}(x_j)]^2}{\sigma^2} \approx m - n - 1, \quad (D.15)$$

so that

$$\sigma_j = \sigma = \sqrt{\frac{\sum_{j=1}^{m} [y_j - \sum_{i=0}^{n} \hat{a}_i x_i^j]^2}{m - n - 1}}. \quad (D.16)$$

In practice it appears that the error estimates from this procedure are more realistic if a fit is made using a polynomial with one order higher than needed for a ‘good’ fit to the data.

Using eq. (D.16) as the estimate of the uncertainty $\sigma$ on each of the measurements $y_j$, the matrix $M_{kl}$ of eq. (D.9) becomes

$$M_{kl} = \frac{m - n - 1}{\sum_{j'=1}^{m} [y_{j'} - \sum_{i'=0}^{n} \hat{a}_{i'} x_{i'}^{j'}]^2} \sum_{j=1}^{m} x_j^k x_j^l. \quad (D.17)$$

The estimate (D.14) of the uncertainty on the fit coefficient $\hat{a}_i$ is now given by

$$\sigma_{\hat{a}_i} = \frac{1}{\sqrt{M_{ii}}} = \sqrt{\frac{\sum_{j'=1}^{m} [y_{j'} - \sum_{i'=0}^{n} \hat{a}_{i'} x_{i'}^{j'}]^2}{(m - n - 1) \sum_{j=1}^{m} x_j^{2i}}} \quad (D.18)$$

When WPtools performs a polynomial regression it generates a plot of the data points and the best-fit curve, along with numerical values of various parameters associated with the fit. Figure D.1 gives an example of a fit to a set of 8 data points of the form $y = x^2$. The fit is to the form $y = a_0 + a_1 x + a_2 x^2$. The fit coefficients are $a_0 = -0.4107$, $a_1 = -0.3274$ and $a_2 = 1.1964$. The uncertainties (standard errors) on the fit coefficients are reported as $\text{SE}(a_0) = 4.0070$, $\text{SE}(a_1) = 2.0429$ and $\text{SE}(a_2) = 0.2216$, as calculated according to eq. (D.18). Note that the uncertainties on coefficients $a_1$ and $a_2$ are larger than the coefficients themselves, which tells us that these coefficients are indistinguishable from zero.

Also indicated on the plot are the values $R^2 = 0.9915$ and $\sigma = 2.8721$. The latter is the uncertainty in the data points $\{y_j\}$, calculated according to eq. (D.16) with $m = 8$ and $n = 2$. The quantity $R^2$ is defined by

$$R^2 = \frac{\sum_{j=1}^{m} [\hat{y}(x_j) - \overline{y}]^2}{\sum_{j=1}^{m} [y(x_j) - \overline{y}]^2}, \quad (D.19)$$

where the average $\overline{y} = \frac{\sum_{j=1}^{m} y(x_j)}{m}$. This is a measure of the “goodness of fit”. If the fit is perfect then $\hat{y}_j = y_j$ for all $j$ and $R^2 = 1$. It is not obvious, but $R^2 \leq 1$ always. The extreme case of $R^2 = 0$ occurs when the fit has the trivial form $\hat{y}(x) = \overline{y}$ for all $x$, which in general is a bad fit. The qualitative conclusion is that if $R^2$ is not close to 1, the fit results are to be regarded with suspicion.
Figure D.1: Sample plot from WPtools Polynomial Fitting.